IonCube Loader is a tool, that's necessary to run files which are encoded with ionCube PHP Encoder. The aforementioned is an app used to make PHP code human unreadable, so as to protect it from reverse engineering or not authorized use. Plenty of script-driven applications, in particular discussion forums, content management systems and electronic commerce solutions are encrypted with ionCube PHP Encoder, which means that if you acquire a script and you find that ionCube is on the list of hosting environment prerequisites, you have to make sure that your website hosting server has the tool pre-installed. While it's not that difficult to install it if you have your own server, it is almost impossible to do that on a shared web hosting server since the PHP environment should be precompiled and all the clients on the server will be affected.
IonCube in Website Hosting
IonCube Loader is supplied with each website hosting that we offer and you can activate it anytime with just a few clicks, so you will be able to employ script applications which need it. You can do this through the PHP Configuration section of your Hepsia Control Panel and all it'll take to enable or disable ionCube is to click a button. The change takes effect within a minute, which means that you can proceed and set up the app that you need right away. The very same section will allow you to change the PHP version that's active for your account, as we support a number of releases on our cutting-edge cloud hosting platform. In case you move to a release that you haven't used so far, you'll need to enable ionCube Loader once again. Experienced users will be able to use a php.ini file in a particular domain folder in order to set a PHP release different from the one for the whole account or enable/disable ionCube Loader.
IonCube in Semi-dedicated Servers
If you aquire a semi-dedicated server plan from our company, you can take advantage of any script-driven app which requires ionCube Loader for the reason that the software tool is available on all of the servers that are part of our revolutionary cloud website hosting platform. We also support various versions of PHP, which means that if you switch from PHP 4 to 5.2 or 5.3, for instance, you can activate ionCube for this particular release with only a click in your Hepsia Control Panel. Our platform will remember your choice, so in case you switch back to the earlier version of PHP, the instrument will already be active. For more tech-savvy users, we also offer the option to select the PHP version and whether ionCube will be active or not for a particular domain without altering the settings for the whole website hosting account. This is done by placing a php.ini file in a domain folder with several lines of program code.